Why am I not able to access Appointment Plus?

Take a look at your browser. Appointments Plus only supports the following browsers without modification:

·         Apple Safari version 8 or higher

·        Google Chrome version 43 or higher

·        Microsoft Internet Explorer version 11 or higher

·        Mozilla Firefox version 39 or higher

If you use Microsoft Internet Explorer version 8, 9, & 10 to use Appointments Plus, please see the below instructions:

 

To update Microsoft Internet Explorer version 8, 9, & 10:

·        Select the tools menu or the gear icon in the upper right and select “Internet Options”.

·        Select the “Advanced Tab” in Internet Options

·        Scroll down and select the checkbox titled “Use TLS 1.1” and “Use TLS 1.2”

·        Select “Apply” in the bottom right

·        Select “OK”

·        Close and reopen Internet Explorer

Once you have re-opened Internet Explorer please select on the Appointments Plus link provided in the Credential Notification email to validate that the Appointments Plus link is currently working for you.

If you have any questions, please contact RAPIDGate Customer Support @ 877-727-4243